[Mailman-Developers] Min requirements for running Mailman?

Mark Sapiro msapiro at value.net
Mon May 30 22:54:38 CEST 2005

Barry Warsaw wrote:
>On Thu, 2004-09-09 at 10:48, Nigel Metheringham wrote:
>> I was certainly unable to take lists to 2.1.5 when I tried recently on
>> full system upgrade - I ended up recreating the lists with significant
>> pain involved.
>Can you provide details?  I consider it a bug that lists cannot be
>upgrade from 2.0.13 to 2.1.6.  You might need to upgrade from 2.0.x
>where x < 13, to 2.0.13 first though.

There have been reports on the mailman-users list of difficulties in
moving/upgrading lists from older versions. After grappling with these
issues in my own mind, I have concluded that the likely explanation is
not that the new Mailman can't update the old list's config.db, but
rather that the marshal format of the old lists config.db is not
compatible with the Python on the new system.

Does this seem reasonable, or am I off track here.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Developers mailing list