[Mailman-Users] Exim errors

Kevin Lee kevin at vulcanind.com
Fri Apr 30 16:20:46 CEST 1999


I am using Debian's GNU/Linux ver 2.1 with exim as my MTA.  I am also going
to post this reply to eht Mailman-Users list also.

First of all I would like to thank Michael Yount for his help.  He was the
person who solved the problem.


This is what Michael wrote:

Okay, here's what's happening.  The directors are run in order,
and the system_aliases director appears first.  The mailman list
address is found in /etc/aliases, so exim says "aha, here
it is," attempts to pipe the mail to the wrapper with no
specified privileges, and bombs with the error you see.

If you placed the mailman director first, you'd have a similar
problem...every alias on your system would be considered
to have user mailman and group list.  That might cause
problems with the other aliases.

I'd suggest the following...
* Take the mailman aliases that use pipes out of /etc/aliases
and put them in their own file.

* Change the mailman director to use that file instead of

* If you're running exim as a standalone daemon, be sure to 
kill -HUP the daemon process after you modify the config file.

I'll be offline until this evening.  If something goes wrong,
please send me the exim errors and I'll make further suggestions,
probably tomorrow morning.



I followed Michael's instructions and moved my mailman aliases out of
/etc/aliases and into /etc/mailman-aliases.  My /etc/mailman-aliases file
looks like the following:

sales:           "|/usr/lib/mailman/mail/wrapper post sales"
sales-admin:     "|/usr/lib/mailman/mail/wrapper mailowner sales"
sales-request:   "|/usr/lib/mailman/mail/wrapper mailcmd sales"
owner-sales:      sales-admin
sales-owner:      sales-admin

estimating:          "|/usr/lib/mailman/mail/wrapper post estimating"
estimating-admin:    "|/usr/lib/mailman/mail/wrapper mailowner estimating"
estimating-requests: "|/usr/lib/mailman/mail/wrapper mailcmd sales"
owner-estimating:    estimating-admin
estimating-owner:    estimating-admin

engineering:           "|/var/lib/mailman/wrapper post engineering"
engineering-admin:     "|/var/lib/mailman/wrapper mailowner engineering"
engineering-request:   "|/var/lib/mailman/wrapper mailcmd engineering"
owner-engineering:     engineering-admin
engineering-owner:     engineering-admin

I then deleted all of the code that I had added to my /etc/exim.conf as per
FAQs, and archives.  I added the following code as Micheal suggested at the
very end of the directors configuration (just before the end statement) in
the /etc/exim.conf file:

  driver = aliasfile
  search_type = lsearch
  file = /etc/mailman-aliases
  modemask = 002
  user = mailman  
  group = list 

I am still getting some cron errors when running run_queue, but the system
is distributing e-mails correctly now.  I just haven't had a chance to look
at the cron errors yet.


At 02:01 AM 4/30/99 -0700, Don wrote:
>I saw your post a few days ago regarding your errors with Mailman and
>Exim, and was hoping to see some replies because I've been having the
>very same problem, but have seen no replies.  Have you gotten some
>replies directly?  If you have could you possibly forward them to me,
>and if you haven't, have you gotten anywhere on solving your problem?
>Would appreciate any help I can get.  I have tried some to get Mailman
>running (actually it is running, I guess, but rather useless unless it
>will actually forward mail) but, after getting stuck, have had to attend
>to other matters for the last week or so, but now would like to get it
>working.  I am also using Debian linux and Exim. Exim seems to be
>working fine in other respects.
>Don MacDougall
>dmacdoug at hsc.usc.edu

Kevin Lee
Vulcan Industries
(205) 640-2433

mailto:kevin at vulcanind.com


More information about the Mailman-Users mailing list