[Mailman-Users] Question

James Strickland james at perforce.com
Thu Jul 22 16:25:13 CEST 1999

On Wed, 21 Jul 1999, Christopher Schulte wrote:

> At 06:17 PM 7/21/99 +0000, you wrote:
>  >Below is what I got when I sent to my test list.
>  >
>  >I am using sendmail 8.9.1 on freebsd 3.2 with mailman-1.0rc3.
>  >
>  >Any suggestions?? I have looked through the email archive with no such
>  >luck althought it has been a long day and I am tired.
>  >   ----- Transcript of session follows -----
>  >554 "|/home/mailman/mail/wrapper mailowner test"... unknown mailer error 2
> This looks to me like you did not configure the wrapper with the correct 
> mail gid.

Maybe.  Maybe he's encountering the same yet-to-be-debugged problem I'm
encountering (see my email of the Monday before last).  To prove which id
sendmail is using I added an alias

gidtest: "|/usr/bin/id >/tmp/gidtest"

then sent mail to gidtest.  The result was:

% cat /tmp/gidtest
uid=1(daemon) gid=1(daemon) groups=1(daemon)

This matches the default used in the install, plus I even tried
reinstalling with --mail-gid=1 explicitly.  Still no luck.

If you think this test doesn't prove what I think it proves, please let me
know.  Alas, I have been too busy to try to debug what's going on with
Mailman.  FYI, I have successfully installed and am using Mailman 1.0b6 on
another machine which is almost identical (FreeBSD, sendmail, Apache).
Hence I am perplexed (and frustrated) by the refusal of something
somewhere to just plain work. :-)  Note that at the time I installed
Mailman the machine was running FreeBSD 2.2.something - this time I'm
installing it on a FreeBSD 3.0 machine.  Maybe there's something in that..

Hopefully by the time I get some time to look at it again, 1.0 will be
out. :-)

James Strickland
Perforce Software

More information about the Mailman-Users mailing list