[Mailman-Users] Urgent: Help, python hanging

Rusty Atkins atkinsr at colltech.com
Tue Jun 6 20:56:16 CEST 2000

Hi all, I have a big list (122,000 people, and no, it's not spam! ;)
that I'm trying to send a message to. 

I'm using python-1.5.2-13 with mailman-2.0beta2 and

The problem is that python is running for about 9 seconds and then
hanging/dying each time after a child process hangs:

(hiding real hostname and the list name to protect the guilty :)

[root at hostname ~mailman]# uname -a
Linux hostname.domain.com 2.2.14-5.0smp #1 SMP Tue Mar 7 21:01:40 EST
2000 i686 unknown

[root at hostname ~mailman] ps -efw | grep python | grep -v grep

nobody   12684 12606  1 13:29 ?        00:00:09 /usr/bin/python -S
/home/mailman/scripts/post listname
nobody   12685 12684  0 13:29 ?        00:00:00 [python <defunct>]

[root at hostname ~mailman]# ps -efw | grep 12606
postfix  12606 12581  0 13:28 ?        00:00:00 local -t unix

[root at hostname ~mailman]# ps -efw | grep 12581
root     12581     1  0 13:27 ?        00:00:00

So it's getting called from the aliases file correctly:

listname: "|/home/mailman/mail/wrapper post listname"


I've tried killing the python processes (it bounces the message back to
the poster) and resending the message and I get the same thing. I've
also tried stopping and starting postfix, which will start python
again.. and it hangs after 9 seconds without ever changing the size of
the queued mail file. 

I've ran ~mailman/bin/check_db and check_perms and all looks fine.

If you have any idea what might be wrong, or how I can go about better
debugging this problem, please let me know.


Rusty Atkins
atkinsr at colltech.com

More information about the Mailman-Users mailing list