[Mailman-Users] Python-2.1 Compatibility?

Jason R. Mastaler jason-dated-7d012d82bc077211 at mastaler.com
Tue Apr 17 18:03:03 CEST 2001

I tried upgrading to Python-2.1 this morning, and qrunner didn't seem
to like this:

From: root (Cron Daemon)
Subject: Cron <mailman at sclp3> /usr/local/bin/python -S /usr/local/mailman/cron/qrunner
To: mailman
Date: 17 Apr 2001 15:49:00 -0000

/usr/local/mailman/cron/qrunner:0: SyntaxWarning: name '_listcache' is assigned to before global declaration
/usr/local/bin/../packages/python-2.1/lib/python2.1/regsub.py:15: DeprecationWarning: the regsub module is
+deprecated; please use re.sub()

I'm running Mailman 2.0.1 -- Are any of the newer releases Python-2.1


More information about the Mailman-Users mailing list