[Mailman-Users] make install error

Phil Stracchino alaric at babylon5.babcom.com
Mon May 28 20:34:46 CEST 2001

On Mon, May 28, 2001 at 12:32:41PM -0400, Barry A. Warsaw wrote:
> >>>>> "v" == venkateswaran  <gv_indian at yahoo.com> writes:
>     v> Still I am in trouble. I have not commented out the line shared
>     v> in Setup. It compiled as a static and could see shamodule.o in
>     v> Modules directory. I did not get any errors while
>     v> installing. run make test, lists the modules with "test_sha"
>     v> without any comments. Still I am getting the same error sha
>     v> module import error. I too tried to install python2.1 also and
>     v> failed to figure it out.
>     v> I do not know what should be the next step.
> I can't imagine what your problem is.  Are you sure that Mailman is
> using the exact same executable as you built and tested?  There isn't
> another Python executable somewhere else on your path that it is
> finding instead.  Try using Mailman's --with-python configure switch.
> Python 2.1 should be as easy as just typing "configure ; make
> install".  When all else fails try that.

I installed Mailman-2.0.5 with Python-2.1, and also had module import
errors.  I discovered that the problem is that Python-2.1's "make install"
installed files into /usr/lib/python2.1 with severely FUBARed permissions.

Try this:

chown -R root.root /usr/lib/python2.1
chmod -R go-w,a+rX /usr/lib/python2.1

Then see if Mailman works better for you.

 Linux Now!   ..........Because friends don't let friends use Microsoft.
 phil stracchino   --   the renaissance man   --   mystic zen biker geek
    Vr00m:  2000 Honda CBR929RR   --   Cage:  2000 Dodge Intrepid R/T
 Previous vr00mage:  1986 VF500F (sold), 1991 VFR750F3 (foully murdered)

More information about the Mailman-Users mailing list