[Mailman-Users] Problems installing 2.0.6 as a different user

Doug Muth dmuth at claws-and-paws.com
Sun Sep 2 01:00:49 CEST 2001

	Hi folks,

	I'm presently running a Mailman 1.1 installation that I'm trying
to upgrade to 2.0.6, and am running into a bit of a problem.  Since I run
multiple installations of Mailman on my system, rather than running it
under the mailman user, I run each installation under its own user.  

	Under normal circumstances, the CGIs are executed as the user on
that machine that owns the installation, with the daemon group (which
Sendmail runs as on my box) having some access as well.  This works fine
with 1.1.

	However, I have a bit of a problem with 2.0.6: the file
cron/qrunner appears to recreate the file lists/<listname>/config.db.  The
end result is that the group ownership on the file is set to the user
owning mailman, and therein is the problem: any programs that Sendmail
spawns can no longer read the file, including the Mailman scripts.

	So, at this point, I'm pretty much out of things to try, other
than to possibly attempt rewriting qrunner to preserve the permissions on
config.db.  And I'm not going to do that, because I have no desire to
create a fork in the code. :-)

	Any suggestions would be much appreciated.  Please CC me, as I am
not subscribed to this mailing list.


<Doug Muth> ----- <http://www.claws-and-paws.com/> ----- <ICQ:  14112246>

More information about the Mailman-Users mailing list