[Mailman-Users] qrunner import error on regex module

Dave Dribin dave-ml at dribin.org
Thu Nov 7 19:34:51 CET 2002

On Wed, Nov 06, 2002 at 11:42:59AM -0600, Dave Dribin wrote:
> Hello,
> My setup is RedHat 7.2 with the default Python RPMs installed, Postfix
> 1.1.10 (installed from source), and Mailman 2.0.13 (installed from
> source).  I installed Mailman with these options:
> ./configure  --with-mail-gid=mailman --with-cgi-gid=www \
>              --with-python=/usr/bin/python2.1

I suspect something is broken with the Python 2.1 installation,
specifically the regex module was never compiled in.  I fell back to
1.5 (i.e. just /usr/bin/python) which *does* have regex, and a flurry
of messages were sent (i.e. all is working).  I'm still baffled as to
how it worked at all.  I *swear* it was working for a month on Python
2.1 before it flaked out.  And I also *swear* that I didn't touch
Python 2.1 (i.e. it's the *same* RPM as the day I installed the
machine).  I must be losing my mind....

Actually, I just thought of theory.  Prior to Oct. 10, all messages
sent just went through.  There were no detained messages, i.e. qrunner
had nothing to do.  Since then, 3 messages have been "detained" for
the admin to look at.  My theory is that a message that goes right
through never needs the regex Python module, but qrunner needs regex,
So for the first month of operation, everything worked, but as soon as
something triggered qrunner, all hell broke lose.  Not only did the
detained messages never go through, but the email to the admin never
went through either.  The only reason I solved the problem is that a
user said that a message never got through.  I also need to check the
Mailman logs more frequently than I do.

In any case, if the "regex" module is absolutely required (as seems to
be the case), shouldn't the "./configure" script check for this and
tell me *before* I install Mailman?  It seems easy enough to detect.

-Dave, confused, but glad all is working

More information about the Mailman-Users mailing list