[Mailman-Users] New apache is causing my mailman to fail...

Steve Rifkin steve410 at cs.jhu.edu
Thu Nov 21 19:03:55 CET 2002

Hi All!

I'm currently running Mailman version 2.0.8.

Until last week, our Apache webserver (1.3.14) interfaced with our Mailman just 

Last week, we needed to upgrade our Apache Web server to 1.3.27.

We also had to upgrade our openssl to the latest version (version OpenSSL 0.9.6g 
9 Aug 2002)

We're also running Python version 2.2.2.

Since then, we've been getting the following error attempting to access mailman 
lists from our website:


Bug in Mailman version 2.0.8

We're sorry, we hit a bug!

Please inform the webmaster for this site of this problem. Printing of traceback 
and other system information has been explicitly inhibited, but the webmaster 
can find this information in the Mailman error logs. 


I even tried reinstalling Python to make sure it saw the updated OPENSSL stuff.

Anyway, from the web, when we do a mailman/listinfo and get the above error, the 
mailman error log reports:

Nov 21 11:03:35 2002 admin(18834): @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
admin(18834): [----- Mailman Version: 2.0.8 -----]
admin(18834): [----- Traceback ------]
admin(18834): Traceback (most recent call last):
admin(18834):   File "/home/mailman/scripts/driver", line 80, in run_main
admin(18834):     import Mailman.pythonlib.cgi
admin(18834):   File "../Mailman/pythonlib/cgi.py", line 31, in ?
admin(18834):     import urllib
admin(18834):   File "/usr/local/lib/python2.2/urllib.py", line 26, in ?
admin(18834):     import socket
admin(18834):   File "/usr/local/lib/python2.2/socket.py", line 41, in ?
admin(18834):     from _socket import *
admin(18834): ImportError: ld.so.1: /usr/local/bin/python: fatal: 
/usr/local/ssl/lib/libssl.so.0.9.6: bad ELF flags value: 768
admin(18834): [----- Python Information -----]
admin(18834): sys.version    = 2.2.2 (#1, Nov 20 2002, 18:28:42) 
[GCC 2.95.2 19991024 (release)]
admin(18834): sys.executable = /usr/local/bin/python
admin(18834): sys.prefix     = /usr/local
admin(18834): sys.exec_prefix= /usr/local
admin(18834): sys.path       = /usr/local
admin(18834): sys.platform   = sunos5
admin(18834): [----- Environment Variables -----]
admin(18834):   HTTP_PRAGMA: no-cache
admin(18834):   PYTHONPATH: /home/mailman
admin(18834):   SERVER_SOFTWARE: Apache/1.3.27 (Unix) PHP/4.2.3 mod_perl/1.27
admin(18834):   SCRIPT_FILENAME: /home/mailman/cgi-bin/listinfo
admin(18834):   SERVER_ADMIN: webmaster at cs.jhu.edu
admin(18834):   SCRIPT_NAME: /mailman/listinfo
admin(18834):   SCRIPT_URI: http://www.cs.jhu.edu/mailman/listinfo
admin(18834):   SERVER_SIGNATURE: <ADDRESS>Apache/1.3.27 Server at 
www.cs.jhu.edu Port 80</ADDRESS>

Note the Import error above.

So... again, it worked until we installed the new Apache and new openssl.  Then, 
it stopped working giving the above errors.  Rebuilding python did not help.

Any ideas of what I can try?  Is there really a bug in our version of Mailman?  
And should I be reinstalling Mailman?  or is there an easier fix?

Thanks a bunch in advance, and if you could seperately CC: me on your post to 
the mailman list, that would be much appreciated.


steve410 at cs.jhu.edu

More information about the Mailman-Users mailing list