[Mailman-Users] Upgrading from 2.0.0 to 2.1.1 using Exim 3.36 - Fixed

Peter van Rensburg peter at thenephilim.net
Thu Feb 13 05:50:55 CET 2003

Well I fixed it, although I'm still not sure where exactly the "1" came
from. Once again the @#($*% python-2.1 from sunfreeware comes back to
bite me, socket.so being linked against libssl.so.0.9.6, I have 0.9.7
installed for openssh and while not paying attention I (fortunately)
compiled it staticly (in /opt), so I just installed the openssl 0.9.6g
package from sunfreeware which installs dynamic libraries. 

I tried Exim's "environment" pipe transport option but that didn't help.
I hacked the mailman wrapper (quick & dirty style;) and added support
for a hard compiled LD_LIBRARY_PATH. Attached is a patch, maybe it'll
help someone out there.  


On Wed, 2003-02-12 at 18:03, Peter van Rensburg wrote:
> Hello
> I removed the old transports from the exim configuration and installed
> the single new transport & single director as per README.EXIM, now I
> just get this:
> xxxxx <xxxx> D=mailman_director T=mailman_transport: Child process of
> mailman_transport transport returned 1 from command: /opt/mailman/mail/mailman
> I cannot figure out what's wrong, where does that error number originate
> from ? run_script always returns 4 if there's a problem? Any clue what 1
> means? There's nothing in /opt/mailman/logs/error, I've ran check_perms,
> all seems fine. 
> Any help would be appreciate, production servers are down and the boss
> is getting pissed.
> Thanks,
Peter van Rensburg <peter at thenephilim.net>

More information about the Mailman-Users mailing list