[Mailman-Users] Problems with permissions on aliases.db file

Brad Knowles brad.knowles at skynet.be
Mon Jun 30 17:54:11 CEST 2003

At 2:57 PM -0500 2003/06/27, Ryan Shultz wrote:

>  I have a problem with the aliases.db file for a postfix install with the
>  newest mailman on rehat 9.  In the maillog of the box every time I send
>  to it it says that permission denied.  I have used the check_perms
>  script and everything is fine.  I am at a loss.  It does not seem to
>  want to work.  It was recognizing the aliases entries before but I must
>  have changed something to make it stop.  Any help?

	This sounds like a postfix problem, not an issue with mailman. 
Have you tried the postfix-users mailing list?

	In general, these files should be owned by "root", and should not 
be group-writable, nor should any of the directories in the path to 
this file be group-writable (i.e., if it's in /etc/postfix, then 
neither /, nor /etc, nor /etc/postfix should be group-writable, and 
they should all be owned by root).  Have you tried running the 
"newaliases" command?

Brad Knowles, <brad.knowles at skynet.be>

"They that can give up essential liberty to obtain a little temporary
safety deserve neither liberty nor safety."
     -Benjamin Franklin, Historical Review of Pennsylvania.

GCS/IT d+(-) s:+(++)>: a C++(+++)$ UMBSHI++++$ P+>++ L+ !E-(---) W+++(--) N+
!w--- O- M++ V PS++(+++) PE- Y+(++) PGP>+++ t+(+++) 5++(+++) X++(+++) R+(+++)
tv+(+++) b+(++++) DI+(++++) D+(++) G+(++++) e++>++++ h--- r---(+++)* z(+++)

More information about the Mailman-Users mailing list