[Mailman-Users] Bug in MM2.1.2 Install

Dave Weiner davew at coyotetechnical.com
Fri May 2 02:05:08 CEST 2003

Richard Barrett <r.barrett at openinfo.demon.co.uk> wrote:

Richard, first off, thanks for responding, but I'm on the list, I don't need
an extra copy :)

> It is cold comfort but it should work.
> I cannot explain why you are having this problem but I install MM from
> source distribution using --prefix=/mailman/run and
> --exec-prefix=/usr/local/mailman as options for ./configure without
> having any problems on Linux (Suse 7.3 distribution).

What version of MM?

> Does the output of the first 10 or so lines of the file
> $build/config.status confirm the --prefix and --exec-prefix options
> on the ./configure are what you put on the command line?

Yes, my settings for --prefix and --exec-prefix are in config.status

> What does the $build/Makefile have to say on the matter of values for
> prefix and exec-prefix.

No matter what values I give --prefix and --exec-prefix when I run
./configure, in the generate Makefile, prefix is set to /usr/local/mailman,
even after doing a 'make distclean' or a blowing away the build directory
and untar fresh.

> What version of what OS are you using and what dose /bin/sh resolve
> to?

Red Hat 7.3 and bash

> Have you tried recreating $build/configure by running the command
> 'autoconf configure.in' in the build directory, and then running the
> configure file that is generated?

No, but I don't think it'll work.  I've looked at configure.in, and I don't
find any code to deal with --prefix and --exec-prefix.  I think a bad
configure file got out into the wild.

> I've run out of guesses.
> Best of luck.



More information about the Mailman-Users mailing list