[Mailman-Users] Mailman CGI not working

Foo, Randy randy.foo at hp.com
Mon Oct 27 23:51:29 CET 2003

Thanks for your help,

However, I've tried changing the group that apache runs httpd under to
www, and that didn't work. For some unknown reason, I cannot get httpd
to run as any id other than apache. The apache conf file says to run
httpd as root, and then it will change over, but I haven't seen that.  I
ran configure again using --with-cgi-id=nobody, and then make install
again and it took this time.  But the CGI still does not run.     I set
the User to nobody, and Group to 99 in the apache httpd.conf file. 

Any other suggestions?


Randy Foo
Unix System Administrator/FW support
The Kemtah Group at Hewlett Packard
Telnet 212-6186

Here's the http.conf setup:

 # If you wish httpd to run as a different user or group, you must run
# httpd as root initially and it will switch.
# User/Group: The name (or #number) of the user/group to run httpd as.
#  . On SCO (ODT 3) use "User nouser" and "Group nogroup".
#  . On HPUX you may not be able to use shared memory as nobody, and the
#    suggested workaround is to create a user www and use that user.
#  NOTE that some kernels refuse to setgid(Group) or semctl(IPC_SET)
#  when the value of (unsigned)Group is above 60000;
#  don't use Group #-1 on these systems!
User nobody
Group #99
#Group #-1

# ScriptAlias: This controls which directories contain server scripts.
# ScriptAliases are essentially the same as Aliases, except that
# documents in the realname directory are treated as applications and
# run by the server when requested rather than as documents sent to the
# The same rules about trailing "/" apply to ScriptAlias directives as
# Alias.
ScriptAlias /cgi-bin/ "/usr/local/apache2/cgi-bin/"

#CGI script enablement directive
/cgi/bin/ /usr/local/apache2/cgi/bin
/mailman/ /usr/local/mailman/cgi-bin

# "/usr/local/apache2/cgi-bin" should be changed to whatever your
# CGI directory exists, if you have that configured.
<Directory "/usr/local/apache2/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all

<Directory "/usr/local/mailman/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all

-----Original Message-----
From: james.osbourn at globalgraphics.com
[mailto:james.osbourn at globalgraphics.com] 
Sent: Friday, October 24, 2003 12:30 AM
To: Foo, Randy
Cc: mailman-users at python.org
Subject: Re: [Mailman-Users] Mailman CGI not working

i have just been setting up a server and had some similar problems, you
need to check that the group that mailman first matches for running its
cgi scripts is the group  that the apache server is running

by default mailman will check for www then www-data and then nobody (see
install doc), on a redhat machine that i have the www and www-data
groups do not exist but nobody does with id 99, and the default RH9
apache server runs as group, and user, apache GUID 48

if you have not used the --with-cgi-gid option then you need to use the
User and Group options for apache to set the server to run as nobody or
whatever group mailman first macthes

once you haev done this try a webpage such as
http://<yourdomain>/mailman/admin, a gotcha that hit me is that just
looking at http://<yourdomain>/mailman/ will not work as there is not
default script or index page for the server to display and you will
probably get an error


At 23/10/2003 23:57:31,
mailman-users-bounces+james.osbourn=globalgraphics.com at python.org wrote:
> Hello,
> I'm a newbie, and have just installed mailman on Red Hat 9, with the 
> apache web server.  None of it was done with rpm, I downloaded, 
> configured and compiled from both apache.org and the mailman site.  
> I've created the 'mailman' list, after having gone through all install

> docs. Mailman's cgi does not work, however.  The documentation said to

> check the apache group setting, which is at the default right now #-1,

> but I have changed it to gid 99, to no avail.  Default cgi group is 
> apparently www in mailman, although the username is nobody in apache 
> (gid 99 in
> redhat) for httpd.  How do I get the mailman cgi to work?  I've set
> scriptalias directive in apache to /mailman/
> I also tried re-running the configure script using the --with-cgi-id ,

> but no matter what it seems to use www.
> The first mailing from the mailman list went to my email ok, returning

> the link <myserver>.vcd.hp.com/mailman/admin/mailman, but all that is 
> returned is the "object not found - the requested URL was not found on

> this server"
> Any help is greatly appreciated.
> Thanks,
> Randy Foo
> Unix System Administrator
> The Kemtah Group at Hewlett Packard
> ------------------------------------------------------
> Mailman-Users mailing list
> Mailman-Users at python.org 
> http://mail.python.org/mailman/listinfo/mailman-users
> Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
> Searchable Archives:
> This message was sent to: james.osbourn at globalgraphics.com Unsubscribe

> or change your options at

> phics.com

More information about the Mailman-Users mailing list