[Mailman-Users] group mismatch error

Sean Butler sean at 2sparrows.org
Wed Feb 4 20:43:44 CET 2004

Here is the error I continue to get, no matter what I try:

Feb  4 14:37:10 east postfix/local[77072]: 0EC763E4B: 
to=<church at 2sparrows.org>, relay=local, delay=0, status=bounced (Command 
died with status 2: "/usr/local/mailman/mail/mailman post church". Command 
output: Group mismatch error.  Mailman expected the mail wrapper script to 
be executed as group "daemon", but the system's mail server executed the 
mail script as group "mailman".  Try tweaking the mail server to run the 
script as group "daemon", or re-run configure,  providing the command line 
option `--with-mail-gid=mailman'. )

Here is what I have done since I first started getting this:

1.  make deinstall; make --with-mail-gid=mailman; make instll

	still same problem

2.  modified the /usr/local/mailman/mail/mailman file to look like

	-rwxrwsr-x  1 root  mailman  18504 Feb  3 16:16 mailman

     It was group dameon before.  After the change, I still get the
     same errors.

3.  Ran check_perms with a -f:

	directory permissions must be 02775: /usr/local/mailman/lists/church (fixing)
        /usr/local/mailman/mail/mailman bad group (has: daemon, expected 
mailman) (fixing)

      Still the same error as above.

check_perms now shows no errros, yet I still can't send mail to 
church at 2sparrows.org.

Any ideas?


More information about the Mailman-Users mailing list