[Mailman-Users] Re: Mailman post from mailman at math.vassar.edu requires approval

Benjamin Lotto lotto at vassar.edu
Thu Jul 1 22:33:33 CEST 2004

On Jul 1, 2004, at 4:23 PM, Dan Phillips wrote:

> On Jul 1, 2004, at 3:11 PM, Benjamin Lotto wrote:
>>> Did you run 'check_perms -f'?
>> Yes (as root).  Followed by unshunt (as mailman) as Dan Phillips 
>> suggested.  I didn't get any errors.  However, I still get the same 
>> error when I try to login to some of my lists webpages, but not 
>> others.  I'm including what shows up immediately below.  I get 
>> similar errors when some of the cron jobs run.
>> Could this have anything to do with the fact that I (naively) set up 
>> a mailman list called mailman, so any e-mail to mailman goes to that 
>> list?  I tried to delete the mailman list (using rmlist) but I got an 
>> error similar to the others I've been describing.
> Certainly, errors in sending the password reminders could be due to 
> messing with a list called mailman, since that is the default "site 
> list" name which is the address of record for sending out those pw 
> reminders, although I don't know what Apple uses. Take a look at the 
> top of mailman/data/sitelist.cfg; the first line should tell you the 
> name of the site list. Another check to make is to run "bin/check_db 
> mailman" and see what it tells you. After running unshunt, is 
> qfiles/shunt now empty?

The "site list" is, in fact, "Mailman".

I ran the commands "check_db -v mailman" and "unshunt" as root.

The results of check_db -v mailman:
List: mailman
    /private/var/mailman/lists/mailman/config.pck: okay
    /private/var/mailman/lists/mailman/config.pck.last: okay
     [Errno 2] No such file or directory: 
     [Errno 2] No such file or directory: 

As far as unshunt is concerned, the result was to reduce the number of 
files in qfiles/shunt to a small number.  There are now some files in 
qfiles/in and lots in qfiles/virgin.

More information about the Mailman-Users mailing list