[Mailman-Users] Group mismatch error

David Relson relson at osagesoftware.com
Wed May 19 22:29:41 CEST 2004

On Wed, 19 May 2004 14:22:45 -0500
David Blomquist wrote:

> I am getting the following error message but my mail server (Postfix)
> is not set up as group "apache". Anybody have an idea why I am getting
> this error message?
> This is the Postfix program at host 'my.mail.host.
> I'm sorry to have to inform you that the message returned
> below could not be delivered to one or more destinations.
> For further assistance, please send mail to <postmaster>
> If you do so, please include this problem report. You can
> delete your own text from the message returned below.
>                         The Postfix program
> <mb_two-request at my.mail.host.com>: Command died with status 2:
>     "/var/mailman/mail/mailman request mb_two". Command output: Group
> mismatch
>     error. Mailman expected the mail wrapper script to be executed as
> one of
>     the following groups: [mail, nobody, mailman], but the system's
>     mail
> server
>     executed the mail script as group: "apache". Try tweaking the mail
> server
>     to run the script as one of these groups: [mail, nobody, mailman],
> or
>     re-run configure providing the command line option:
>     '--with-mail-gid=apache'.

Sounds familiar!  Check the ownership of the aliases file, i.e.
/var/lib/mailman/data/aliases.  If recollection serves, postfix sets the
gid to match that file when it invokes mailman.



More information about the Mailman-Users mailing list