[Mailman-Users] vhosts & list are created but I still get 404 notfound error on admin pages

Mark Sapiro msapiro at value.net
Tue Nov 23 17:39:32 CET 2004

ShiroTora Administrative Account wrote:

>I am trying to add new lists to my Mailman config.  1 list was setup by 
>my admin and I have followed the instruction I was given to setup new 
>lists.  However I can't seem to get any of the admin pages (aside from 
>the 1st list installed by my admin) to show up. 
>I carefully edited the mm_cfg.py file under
>/local/mailman/Mailman and added 1 add_virtualhost line for each of the 
>needed domains
>add_virtualhost('www.example.us', 'example.us')
>I notice that seems to have updated mm_cfg.pys file automatically.  
>However I still can't get my admin page(s) that were emailed to me by 
>mailman to work/show up.  I still get a 404 not found error...

The list domains are probably OK as evidenced by the admin URL in the
e-mail being correct.

It seems like you don't have the appropriate ScriptAlias or whatever
directive for the virtual domains in your web server configuration.
>From the INSTALL document:

    - Configure your web server to give $prefix/cgi-bin permission to
      run CGI scripts.  You probably need to be root to do this.

      The line you should add might look something like the following
      (with the real absolute directory substituted for $prefix, of

          Exec          /mailman/*      $prefix/cgi-bin/*
          ScriptAlias   /mailman/       $prefix/cgi-bin/

      Consult your web server's documentation for details.

I don't know much about configuring Apache and I know nothing about
other web servers, but in Apache at least, if the original ScriptAlias
directive is inside a <VirtualHost> ... </VirtualHost> section it will
only apply to that virtual host.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list