[Mailman-Users] Compile Problem: msgmerge/gettext wants automake 1.8?!

Tokio Kikuchi tkikuchi at is.kochi-u.ac.jp
Thu Oct 7 15:28:57 CEST 2004

Aaron The Young wrote:

>> Solaris 8 has no msgmerge. You have to install GNU gettext.
>> Or, you can download latest messages/Makefile.in from CVS
>> (Release_2_1-maint branch) and restart installation from
>> 'configure'.

Sorry my comment was inaccurate. Actually, you can safely skip
the msgerge step when installing. msgmerge is needed for the
translaters but not for the site managers. New Makefile.in
in CVS skips this step if msgmerge is not available or get
some error. You have to install GNU gettext only if you want to
translate and use msgmerge which is included in the GNU distro.
Python gettext.py is included in the mailman distribution.

>> You can get the latest CVS for the Release_2_1-maint by
>> $ cvs -z3 -d:pserver:anonymous at cvs.sourceforge.net:/cvsroot/mailman \
>>       co -r Release_2_1-maint mailman
> Well, by deduction and some searching I was able to figure out I needed
> gettext.  Thanks.
> However, it appears gettext needs automake 1.8 and all I can get my hands
> on is 1.8b and 1.9.  When I try to run make, I get:

Tokio Kikuchi, tkikuchi@ is.kochi-u.ac.jp

More information about the Mailman-Users mailing list