[Mailman-Users] Authorized Users

Robert Haack haack at nclack.k12.or.us
Thu Oct 7 23:19:49 CEST 2004

>> On Wed, Oct 06, 2004 at 10:02:48AM -0700, Robert Haack wrote:
>>> Ok, I got the patch and applied it and I checked the source files 
>>> and the patches are applied.  Then I tried it out and it didn't work 
>>> so it dawned on me that I need to compile it first.  I've tried to 
>>> compile it but I get the following error:
>> Normally you would apply it to the source of Mailman, and the
>> 'make install' step would compile it for you.
>>> root at nclack Gui]# python -O GUIBase.py   (I've tried it with and 
>>> without the -O)
>>> Traceback (most recent call last):
>>> File "GUIBase.py", line 22, in ?
>>>  from Mailman import mm_cfg
>>> ImportError: No module named Mailman
>> I suspect you are applying it directly to your Mailman
>> installation.  The easiest thing to do would be to just remove
>> the old GUIBase.pyc file.  If the directory has mailman group
>> write permissions, the compiled file will be automatically
>> written the next time it is used.
>> (And remember to restart mailman patching.)
> Ok, I deleted the files GUIBase.pyc, GUIBase.pyo, Moderate.pyc, and 
> Moderate.pyo.  Then just to make sure that Mailman was restarted I 
> rebooted the server.  (I know I could have done this differently but 
> it was late and I was too lazy to do it another way).  But this still 
> is not working for me.  I did check the the GUIBase.pyc and 
> Moderate.pyc files are now back so I know that they recompiled 
> themselves.
> Here is what I have done. 1) I created a list called test and 
> subscribed myself using my work email address.
> 2) I created another list called Auth_users and I subscribed myself 
> using my home email address.
> 3) I went into the test list serv under Privacy Options, Sender 
> Filters and input @Auth_users in the accept these non-members.
> Then I send a message from my home email address and I get a message 
> back telling me the my message has to be approved by the moderator.  
> So what's going on and why didn't it go through?
> Thank You

Ok, this gets more curious now.  I created another list called 
Authorized and I put my alternate email address in that list.  Then I 
changed the test list so so that the "accept these non-members" had 
@authorized.  I got one message through but then I could not longer seem 
to get into the lists test or authorized via the web interface or via 
the command line.  So I deleted both of these lists and started fresh.  
I created test as a list again but this time I gave my authorized list a 
new name, nclack.  I then made it so that @nclack was sin the "Accept 
these non-members".  I sent two messages, one as a member of the list 
test and then the other as the user I input in the nclack list.  I got 
no messages at all, so I stopped Mailman and then restarted it.  Within 
two minutes I had both of my emails.  I'm not sure what is going on here 
but I found this rather odd. 

Robert Haack
Programmer Analyst
North Clackamas School District #12
haack at nclack.k12.or.us

More information about the Mailman-Users mailing list