[Mailman-Users] Mailman not sending out emails

Steph Smith stephanie at thinkers.org
Fri Oct 22 16:41:21 CEST 2004

We've had mailman 2.1 up and running for a while now. We host lists for
a number of different domains, and have been using the virtual host
support. I've just set up a new virtual domain, however, and have run
into some wonkiness that I can't track. Its only happening with this one
virtual domain (listserv.kw-php.org), but it does happen with all of the
lists on the domain.

I'm still a little fuzzy on what exactly is happening, but what it
*looks like* is this:

* I create a new list with the create script
* I test the list by sending a sunscribe request through the listinfo
  page; it works as expected
* I test the list by sending a message to the list; it comes through as
* I then go on to customize the list. I haven't been able to pinpoint
  anything in here that actually causes the problem; its all standard
  stuff, that I've been doing on other lists that do work:

  Change privacy options-sender to allow anyone to send to the list

  Remove pre-existing reply-to headers, and set the reply-to to an 
  explicit address

  Add a list alias to the recipients list (so that we can send 
  to @kw-php.org, rather than to @listserv.kw-php.org)

  Restrict the members list to admin only

  I think that's about it.

* When I go back to check the list again, Mailman no longer sends mail
  out. It will receive posts (and I can verify that they are in the
  archive), but it doesn't distribute them to the subscriber list. If
  I fill out a subscription request, it doesn't sent out the
  confirmation email. If, as a subscriber, I ask it to send me my
  password, it fails to do this as well.

I imagine that its something very stupid and obvious that I've done or
not done. The fact that it worked in the first place does confuse
me--none of the things that I changed should have broken anything (and,
indeed, never break anything for other domains). 

Just to overview the steps I took in setting up the virtual domain:

* added listserv.kw-php.org to /etc/mail/mailertable, /etc/mail/access,
  and /var/mailman/Mailman/mm_cfg.py

* added listserv.kw-php.org to the DNS, both as an A record (pointing to
  the server's IP), and as an MX

I've been hoping to find something in the logs, but haven't found
anything at all in /var/mailman/logs. Actually, its empty, so I wonder
if logging is somehow not turned on??

I've also tried looking through the sendmail logs, but I'm not 100% what
I'm looking at all the time ;) I haven't found anything relating to the
domain in question which looks like an error. Just nothing which looks
like an attempt to send anything from the list. So I don't think its
making it even that far.

At this point, I'm stumped. If anyone can suggest places that I might
look, to ramp up the troubleshooting, how I can be sure that logging is
working for Mailman, etc., it would be greatly appreciated! I don't know
python from jack, but I'm not afraid to look at code either ^_- 

If there's any additional information I can provide, which I've
forgotten, please let me know! This is running off of RedHat box, and
we're using Sendmail. 

Thanks in advance!

The personal computer market is about the same size as the total potato chip
market.  Next year it will be about half the size of the pet food market and
is fast approaching the total worldwide sales of pantyhose"
		-- James Finke, Commodore Int'l Ltd., 1982

More information about the Mailman-Users mailing list