[Mailman-Users] Exim and Mailman, address_pipe and never_users

Mark Sapiro msapiro at value.net
Fri Apr 8 06:27:01 CEST 2005

Daevid Vincent wrote:

>I didn't see this come through the list since yesterday, 
>so I figured I'd send it again...

It was on the list yesterday and Brad's reply is at

Brad's reply is that this is an Exim question and Exim lists, etc are
much more likely to provide a useful response than this list.

In order to prove Brad correct, I'll point out what I (not an Exim guy)
see, but I can't tell you what to do about it because I don't know. 

>I'm running Gentoo with Exim 4.43-r2 and Mailman 2.1.5-r4.
>When I send a message to my list "rbc", it never gets sent. 
>The logs have some entries that look like this:
>Apr  6 00:42:21 [exim] 2005-04-06 00:42:21 no host name found for IP
>Apr  6 00:42:21 [exim] 2005-04-06 00:42:21 1DJ5B7-0006dd-Cc <=
>daevid at daevid.com H=(locutus) [] P=esmtpsa
>X=TLSv1:RC4-MD5:128 A=login:dae51d S=569
>Apr  6 00:42:21 [exim] 2005-04-06 00:42:21 1DJ5B7-0006dd-Cc User 0 set
>for address_pipe transport is on the never_users list
>                - Last output repeated twice -
>Apr  6 00:42:21 [exim] 2005-04-06 00:42:21 1DJ5B7-0006dd-Cc ==
>|/usr/local/mailman/mail/mailman post rbc <rbc at daevid.com>
>R=system_aliases T=address_pipe defer (-29): User 0 set for address_pipe
>transport is on the never_users list

This seems to me to be saying that Exim is trying to pipe the message
(presumably to the mailman wrapper), but it is running as User 0
(root) which is on some Exim configured list (never-users) of users
not allowed to do this.

>I've googled for address_pipe and never_users and it seems to be Exim
>related, but I really don't know what to change to fix this. I used to
>run mailman 2.0 with sendmail on an old RH8 box. Exim is all new to me
>too. Sorry if this is off topic.

I don't know what to change either.

>I tried to follow the instructions here, but still no joy.
>Something isn't right:
>daevid bin # exim -bt rbc at daevid.com
>rbc at daevid.com -> |/usr/local/mailman/mail/mailman post rbc
>  transport = address_pipe
>When it should say:
>router = mailman_router, transport = mailman_transport

Actually, I think the above is right. Mail to the list post address
(rbc at daevid.com) should be piped to the mailman wrapper exactly as
shown in the response. The router = and transport = stuff is an Exim
incantation that tells Exim to do its Mailman magic which results in
the pipe as shown.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list