[Mailman-Users] Mailman error when sending to test-subscribe

Mike Hanby flakrat at yahoo.com
Mon Aug 8 23:31:24 CEST 2005

Howdy, I'm have the following setup:

      Postfix:    2.2.3

      Mailman:    2.1.6



      Here's the error I see in my /var/log/maillog after sending a mail to
test-subscribe at mydomain.com


to=<test-subscribe at mydomain.com>, relay=local, delay=1, status=bounced
(Command died with status 2: "/usr/local/mailman/mail/mailman subscribe
test". Command output: /usr/bin/python: can't open file
'/usr/local/mailman/scripts/subscribe' )


      I looked in /usr/local/mailman/scripts and sure enough that script
isn't there!




I installed from source using the configure command:

      ./configure --with-mail-gid=nogroup


Based on one of the Postfix install guides, I have these settings in my
/etc/aliases file (and in the aliases.db created by ./bin/genaliases)

      test:              "|/usr/local/mailman/mail/mailman post test"

test-admin:        "|/usr/local/mailman/mail/mailman admin test"

test-bounces:      "|/usr/local/mailman/mail/mailman bounces test"

test-confirm:      "|/usr/local/mailman/mail/mailman confirm test"

test-join:         "|/usr/local/mailman/mail/mailman join test"

test-leave:        "|/usr/local/mailman/mail/mailman leave test"

test-owner:        "|/usr/local/mailman/mail/mailman owner test"

test-request:      "|/usr/local/mailman/mail/mailman request test"

test-subscribe:    "|/usr/local/mailman/mail/mailman subscribe test"

test-unsubscribe:  "|/usr/local/mailman/mail/mailman unsubscribe test"


More information about the Mailman-Users mailing list