[Mailman-Users] Mailman under Cygwin - won't add list

Ben ben at ahualoa.net
Thu Dec 22 23:28:09 CET 2005


Thanks very much for continuing to try to help..

> >I tried explicitly forcing permissions with 'chmod 777 
> >config.pck', and that made the Admin page work.  So, the
> >"660" permissions are the problem, not the owner/group.
> >This seems to be a widespread issue with Mailman under Cygwin - 
> >permission don't behave as under Unix, so Mailman chokes easily.

> Here's how you can make it work.
> From your previous posts, I think your web server runs in the
> Administrators group. What are you running as a mail server? 
> I use Exim under Cygwin and that works well and integrates 
> well with Mailman.

I run exim too, and it works fine.  Getting mailman to talk to exim is a
step I haven't even gotten to yet, so far I am just trying to get
Mailman to create a list.

> you need to make your 
> mailman user a member of the Administrators group, not mm, 
> and reconfigure Mailman with --with-groupname, --with-cgi-gid 
> and --with-mail-gid all equal to Administrators. Then 
> reinstall with 'make install' and run 'bin/check_perms -f' to 
> make sure things are OK.

I have tried this.  However, I get the exact same error as before:

admin(704):   File "/usr/local/mailman/Mailman/MailList.py", line 591,
in __load
admin(704):     fp = open(dbfile)
admin(704): IOError: [Errno 13] Permission denied:

I have attached the whole error log in case it helps.
The "config.pck" file exists, and it has 660 permissions:
	-rw-rw----  1 Ben None 3607 Dec 22 12:10 config.pck

As before, it is the 660 permission bits, not the owner/group, which is
causing Mailman to choke.  I can't understand why Mailman's 'newlist'
uses this permission mask to create files which Mailman will
subsequently refuse to read.

Any other ideas?


More information about the Mailman-Users mailing list