[Mailman-Users] Mailman under Cygwin - won't add list

Ben ben at ahualoa.net
Fri Dec 23 02:36:06 CET 2005


> Aha!  Well, maybe that's the only functional workaround!  I 
> will try re-configure and re-install with 
> "--with-mail-gid=None --with-cgi-gid=None 
> --with-groupname=None" and see if it gets further.

To continue the story.  I tried this, and web access produced the error
that Apache is running it from group "Administrators", not "None".  So
next, I tried:

./configure --with-mail-gid=None --with-cgi-gid=Administrators

Not much better results.  Using "addlist" does seem to succeed.
Attempting the web interface now gives the classic:
"We're sorry, we hit a bug! [...] the webmaster can find this
information in the Mailman error logs."

However, this time there is no error log; /usr/local/mailman/logs is

I don't know if we've exhausted all possible combinations of mail-gid,
cgi-gid, and groupname, but it sure feels elusive.

You mentioned that you _have_ seen it work with user 'Mark' and group
'None'.  Do you have any record of what you passed to ./configure in
this case?


More information about the Mailman-Users mailing list