[Mailman-Users] Illegal command: mailcmd

Dr. Jones drjones at vii.com
Fri Feb 18 19:18:05 CET 2005

I started this morning, working through Rich Price's configuration list, 
at http://www.linuxgazette.com/node/618
I checked each item, and made sure it was set up as his script directed. 
Everything tested out correct until I 'replied' with the confirmation 
email sent to me from the list, getting the following response:

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

  pipe to |/var/lib/mailman/mail/wrapper mailcmd test
    generated by test-request at fyrenice.com
    local delivery failed

The following text was generated during the delivery attempt:

------ pipe to |/var/lib/mailman/mail/wrapper mailcmd test
       generated by test-request at fyrenice.com ------

Illegal command: mailcmd

------ This is a copy of the message, including all the headers. ------

Return-path: <jssdc1 at qwest.net>
Received: from mgr2.xmission.com ([])
	by fyrenice.com with esmtp (Exim 4.43)
	id 1D2CQe-00040r-0m
	for test-request at fyrenice.com; Fri, 18 Feb 2005 11:00:37 -0700
Received: from [] (helo=mgr1.xmission.com)
	by mgr2.xmission.com with esmtp (Exim 4.34)
	id 1D2CQc-0000NV-SZ
	for test-request at fyrenice.com; Fri, 18 Feb 2005 11:00:34 -0700
Received: from [] (helo=[])
	by mgr1.xmission.com with esmtp (Exim 4.34)
	id 1D2CQb-0001DE-6H
	for test-request at fyrenice.com; Fri, 18 Feb 2005 11:00:34 -0700
Message-ID: <42162D3D.7000505 at qwest.net>
Date: Fri, 18 Feb 2005 11:00:29 -0700
From: Bonez <jssdc1 at qwest.net>
User-Agent: Debian Thunderbird 1.0 (X11/20050116)
X-Accept-Language: en-us, en
MIME-Version: 1.0
To:  test-request at fyrenice.com
References: <mailman.0.1108745246.15044.test at fyrenice.com>
In-Reply-To: <mailman.0.1108745246.15044.test at fyrenice.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
Subject: Re: confirm c33c47c5d366f2400b6efc765052720fe0cc33a4
X-Spam-Checker-Version: SpamAssassin 3.0.2 (2004-11-16) on mgr1.xmission.com
X-Spam-Status: No, score=-5.9 required=8.0 tests=ALL_TRUSTED,BAYES_00,
	T_TM2_M_HEADER_IN_MSG autolearn=disabled version=3.0.2
X-SA-Exim-Mail-From: jssdc1 at qwest.net
X-SA-Exim-Version: 4.2 (built Tue, 25 Jan 2005 19:36:50 +0100)
X-SA-Exim-Scanned: Yes (on mgr1.xmission.com)

test-request at fyrenice.com wrote:

After changing everything in my exim, exim4 and apache config files, I ran /usr/lib/mailman/bin/mailmanctl restart   it restarted ok....

I send a message to the newly created list test at fyrenice.com and I get a message back telling me it's waiting for administrator approval.. 

I am grateful for any insight that can get me on the road with Mailman...instead of spinning my wheels with it. 

Dr. Scott S. Jones
Hands-On Chiropractic 
IRC: irc.freenode.net #utah
Yahoo: sanchiro12

More information about the Mailman-Users mailing list