[Mailman-Users] Problems with SUSE Linux 9.1 YOU upgrade from 2.1.3Mailman to 2.1.4 Mailman.

Mark Sapiro msapiro at value.net
Tue Jan 25 21:03:32 CET 2005

Tim Smith wrote:
>Just wanted to make a report here about some problems I had upgrading
>Mailman from 2.1.3 to 2.1.4 using Yast Online Update (YOU) in Suse 9.1
<error details snipped>
>I  got some help from Don Burns from this list, he told me all I need
>to do is install python-xml.  (Thanks Don!!)
>So, I used the trusty YAST and searched for python-xml and installed it.
>Wham-Bam, it works.
>I guess 2.1.4 version expects python-xml as a depends, whereas the
>earlier versions didn't care about that.

Actually, this problem does not occur in base Mailman 2.1.4. It is
caused by a patch which is apparently being distributed by SuSE which
uses an HTML escape routine from the Python xml library which for some
reason is not installed by default on SuSE.

A modified version of this patch which uses the Mailman Utils.websafe()
method has been incorporated in source in Mailman 2.1.6b1.

Someone might want to ask SuSE why they are distributing and installing
this patch without checking the required dependency.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list