[Mailman-Users] "No such list mailman" after creating list

John Dennis jdennis at redhat.com
Wed Jul 20 18:44:10 CEST 2005

On Wed, 2005-07-20 at 12:25 -0400, Josh Simoneau wrote:
> Greetings,
> Installed 2.1.5 today and have been tinkering. I followed the
> installation document and everything went fine, except this one problem.
> I can create lists (such as the mailman list) and mailman emails the
> given user to let them know about the new list. I can create new lists
> from the command line, no errors, email sent out. When I execute
> "list_lists" all the lists I have created are displayed as expected.
> However, if I go to http://mydomain.com/mailman/admin/mailman at the top
> of the mailman page it says "No such list mailman" same goes for other
> lists I have created (No such list anotherlistname). If I view the error
> log, it says "admin.py access for non-existent list: mailman". So
> apparently something is not seeing the list as existing.
> Another interesting thing is when I try to create a list using the web
> interface, it tells me "Error: You are not authorized to create new
> mailing lists". I have tried both the site admin and list creator
> passwords, I have tried resetting them to new passwords, nothing works.
> Can someone point me in the direction I should look to resolve this?

I suspect you may have a permissions problem when executing code via the
web interface such that mailman does not have permission to read its
files when invoked from a cgi script.

Were you the mailman user when you created those initial lists?

Are the files in mailman/cgi-bin suid mailman and group mailman?
Are the list files that were created group mailman?

You might try running mailman/bin/check_perms and if there are problems
run it again with the -f argument to "fix"

Also make sure what you used as --with-cgi-id --with-cgi-gid when you
built mailman matches the id's used by your webserver.
John Dennis <jdennis at redhat.com>

More information about the Mailman-Users mailing list