[Mailman-Users] SMTPDirect issues (Name or service not known)

Meike Aulbach sonne at sunduin.net
Fri Jun 10 10:17:02 CEST 2005

Hello all,

I'm currently in the process of setting up a mailinglist with mailman.
The installation process worked fine, mails are correctly delivered
to mailman by exim:

    mainlog.1:2005-06-09 22:00:38 1DgTCg-0000LI-Im ** xx-ml at zzzzz.net
    F=<sender at xyz.net> R=mailman_router T=mailman_transport: Child process
    of mailman_transport transport returned 2 from command:

In fact mailman fails to deliver mails to any recipient. The
smtp-failure log says for each subscriber:

    Jun 09 22:00:35 2005 (32666) delivery to xxx at zzzz.net failed with
    code -1: (-2, 'Name or service not known')

As I googled a lot yesterday, I know that this is an issue on the name
resolving level. It appears when doing a telnet connect to an unknown
hostname.  But I fail to reproduce this error when connecting manually
to the configured hostname or localhost with telnet or even python and

I have added the following lines from Default.py to mm_cfg.py:

SMTPHOST = 'localhost'

Now these are the default values, but I tried a lot of other values
on them, e.g. 'mx-name', 'mx-IP', '' for SMTPHOST, 25 for
SMTPPORT). After every change to the values in mm_cfg.py I did a
restart of mailman. (/etc/init.d/mailman restart on Debian, or is
there anything else that needs to be restarted?)

localhost, mx-name etc. are in fact resolvable. Their IP-addresses
are in /etc/hosts, /etc/host.conf is set to order hosts,bind.

I connected to python manually like suggested in the thread on this
list only recently ([Mailman-Users] Mailman just doesn"t send the
messages... :-():

zzzzz:~# python
Python 2.3.5 (#2, Feb  9 2005, 00:38:15) 
[GCC 3.3.5 (Debian 1:3.3.5-8)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import smtplib
>>> SMTPHOST = 'localhost'
>>> SMTPPORT = 0
>>> x = smtplib.SMTP()
>>> x.connect(SMTPHOST,SMTPPORT)
(220, 'mx.zzzzz.net ESMTP Exim 4.50 Fri, 10 Jun 2005 09:58:50 +0200')
>>> x.quit()

So the default values (localhost,0) _should_ work for me, but apparently
they don't. I tried the manual python connect with mx-name and additionally
sent out an e-mail with the smtplib-module, and I simply cannot
reproduce the "Name or service not known" error at any step of the mail
sending process. The hostname of the machine (/etc/hostname) is also
in /etc/hosts and can be resolved (checked with telnet hostname 25).

I went so far and edited SMTPDirect.py just to find out whether the
values of SMTPHOST and SMTPPORT maybe are not reached through to the
module from mm_cfg.py:

        #self.__conn.connect(mm_cfg.SMTPHOST, mm_cfg.SMTPPORT)
	self.__conn.connect('localhost', 0)

But mails are still not delivered. I really know nothing about python,
so maybe this is due because SMTPDirect.py is compiled to SMTPDirect.pyo
and SMTPDirect.pyc, so my changes to SMTPDirect.py are never regarded
by the program? I don't really want to make changes to the SMTPDirect-
module, so maybe anyone here can point out to me where and how I could
go on with debugging this issue? :)

I'd be very glad to hear from you!

Best wishes,

Meike Aulbach <sonne at sunduin.net>

More information about the Mailman-Users mailing list