[Mailman-Users] 2 initial config problems (virtual hosts andpermissions)

Mark Sapiro msapiro at value.net
Tue Mar 1 04:30:21 CET 2005

FH wrote:
>1) Error: Unknown virtual host: machine
>I was able to create the mailman list via the cli (step 8) w/o any problems. 
>When I try creating a list via the web though I get the above error.  I've
>played around w/ a few combinations of machine machine.domain.tld etc in the
>mm_cfg.py file and the add_virtualhost parameter but I still either get the
>error or I get another page which says something about a "bug" in the program
>(funny thing is even when I get this page the list is created).  

This error occurs because the hostname of the URL used to access the
list create web page is not a key (one of the "URL host" entries) in
the VIRTUAL_HOSTS dictionary.

>FWIW as I mentioned the machine is also our mail server, the hostname command
>returns MACHINE (in case that's important).  The DNS name (aka it's not a
>CNAME) of the machine is MACHINE.DOMAIN.TLD (which is also the
>DEFAULT_URL_HOST [set via the configure option]), email though is addressed to
>@DOMAIN.TLD (which is also the DEFAULT_EMAIL_HOST [set via the configure
>option]).  As mentioned the error just says "MACHINE" so I've tried things
>like add_defaultdomain ('MACHINE', 'DOMAIN.TLD')

What's this? Do you mean

add_virtualhost('MACHINE', 'DOMAIN.TLD')

which is what you should do to allow 'MACHINE' to be a URL host.

>but that's when I get the
>other "bug" page (apologies I don't have a copy handy but if it's important I
>can probably regenerate it).

If it resulted after adding the above add_virtualhost() in mm_cfg.py, I
don't know why without seeing it.

If you're not actually using virtual hosts, you can set


in mm_cfg.py, and it will avoid checks like the one that produces the
above error.

>Also I noticed when I pull up the
>http://machine/mailman/admin page at the bottom is says "Send questions and
>comments to mailman at MACHINE" that's it not mailman at MACHINE.DOMAIN.TLD.  Is
>that somehow related?

Here again, the host name part of the URL ('machine' in the case of
http://machine/mailman/admin) is looked up in the VIRTUAL_HOSTS
dictionary and the corresponding email host is used inless there is no
such key in which case just the host name is used.

> What's the appropriate syntax so that MACHINE is an
>"acceptable" virtual host.

add_virtualhost('MACHINE', 'DOMAIN.TLD')

>BTW in case it's related I don't have any virtual hosts set in postfix and
>mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
>myhostname = MACHINE.DOMAIN.TLD
>mydomain = DOMAIN.TLD
>2) Looking at the maillog file I'm seeing this error occasionally
>Feb 28 16:31:31 MACHINE postfix/postalias[1765]: [ID 947731 mail.crit] fatal:
>open /local/home/mailman/data/aliases.dir: Permission denied
>Applicable info for this error includes:
>MACHINE# ls -al /local/home/mailman/data/
>total 44
>drwxrwsr-x   2 root     mailman      512 Feb 28 16:38 ./
>drwxrwsr-x  20 root     mailman      512 Feb 28 16:02 ../
>-rw-r-----   1 root     mailman       41 Feb 28 16:22 adm.pw
>-rw-rw----   1 root     mailman     1165 Feb 28 16:38 aliases
>-rw-r-----   1 mailman  mailman        0 Feb 28 16:38 aliases.dir
>-rw-r-----   1 mailman  mailman     1024 Feb 28 16:38 aliases.pag
>At one point I did chown aliases* to mailman but it has since reverted.  When
>I originally configured mailman I used the --with-mail-gid=postdrop and I
>didn't specify a username (there is obviously a mailman user ;)).  Although
>the install.txt file recommended using hash my install of postfix has problems
>w/ that so I'm using: 
>alias_maps = dbm:/etc/mail/aliases,dbm:/local/home/mailman/data/aliases
>All things postfix are running as the user postfix, all things mailman
>(qrunner is the only continuous process right?) are running as mailman.  I did
>put the postfix "user" in the mailman group (mailman isn't in there though)

The 'mailman' user should definitely be in the 'mailman' group.

>thinking that may help but it didn't seem too.  BTW the apache server is
>mostly running as nobody, there is one instance that ends up as root.  (The
>apache server is brand new too but that install/config seems to have gone ok. 
>Eventually though I want to clear up the 1 root instance and integrate SSL in
>but I figured it was best to get the above issues worked out first ;))
>What are the proper owner/permission settings for these files?

Have you tried bin/check_perms?

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list