[Mailman-Users] Unable to access web interface

William McLain wrmclain at e-connexions.net
Sun May 15 09:50:44 CEST 2005

We recently started a new installation on a Mailman list on a new server,
and transferrred several lists from another server.  One list with about
4000 subscribers was not configured properly (left unmoderated) resulting in
several auto-replies to get through which then resulted in a mass reply of
many subscribers that ended up in using almost all of the servers resources.
In an effort to shutdown and clean up the list and traffic, the log files
were removed and then recreated but with the wrong permissions which
resulted in several "unable to write" errors.  One of these caused the web
interface to come up with this error

Bug in Mailman version 2.1.5

We're sorry, we hit a bug!

If you would like to help us identify the problem, please email a copy of
this page to the webmaster for this site with a description of what
happened. Thanks!

Traceback (most recent call last):
  File "/usr/local/mailman/scripts/driver", line 68, in run_main
  File "/usr/local/mailman/Mailman/Logging/StampedLogger.py", line 52, in
    Logger.__init__(self, category, nofail, immediate)
  File "/usr/local/mailman/Mailman/Logging/Logger.py", line 49, in __init__
  File "/usr/local/mailman/Mailman/Logging/Logger.py", line 67, in __get_f
  File "/usr/local/lib/python2.4/codecs.py", line 607, in open
    file = __builtin__.open(filename, mode, buffering)
IOError: [Errno 13] Permission denied: '/usr/local/mailman/logs/error'

Subsequently, the permissions and ownerships of the log files were repaired.
We finally got mailman to stabilize and it seems to be working properly
except that the web interdace still comes up with the above error and will
not allow access to the administration of the list.  I have a feeling that
this error is not generated dynamically on each access to the web interface,
but rather it is generaterd from a file that was saved when the error
ocurred.  I have searched through all the directories within Mailman and
have not been able to locate anything that may be the cause of this.  How
can I get rid of this "error" and get our web interface back.  Any list
tried on the web interface has the same error message with only the
applicable parts changing (location of the particualr lists).

Any help in resolving this problem would be greatly appreciated.

Thanking you all in advance,

William McLain

More information about the Mailman-Users mailing list