[Mailman-Users] Unable to access web interface

Mark Sapiro msapiro at value.net
Mon May 16 03:00:07 CEST 2005

William McLain wrote:

>IOError: [Errno 13] Permission denied: '/usr/local/mailman/logs/error'
>Subsequently, the permissions and ownerships of the log files were repaired.
>We finally got mailman to stabilize and it seems to be working properly
>except that the web interdace still comes up with the above error and will
>not allow access to the administration of the list.  I have a feeling that
>this error is not generated dynamically on each access to the web interface,
>but rather it is generaterd from a file that was saved when the error
>ocurred.  I have searched through all the directories within Mailman and
>have not been able to locate anything that may be the cause of this.  How
>can I get rid of this "error" and get our web interface back.  Any list
>tried on the web interface has the same error message with only the
>applicable parts changing (location of the particualr lists).
>Any help in resolving this problem would be greatly appreciated.

Can you administer other lists? Does mailman write to other log files
successfully? Does /usr/local/mailman/logs/error exist? if so, you
might try moving it elsewhere and let Mailman create a new one and see
if that helps.

I suspect there is some error in the config.pck or some other file for
the list and then the failed attempt to log *that* error is what you
see on the bug page.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list