[Mailman-Users] Problem with Postfix virtual Domains

Mark Sapiro msapiro at value.net
Thu Oct 27 16:10:55 CEST 2005

Jan-Simon Winkelmann wrote:
>As soon as I change the config to:
>DEFAULT_EMAIL_HOST = 'lists.webnauts.net'
>DEFAULT_URL_HOST = 'www.webnauts.net'
>MTA = 'Postfix'
>POSTFIX_STYLE_VIRTUAL_DOMAINS = ['lists.webnauts.net']
>I want this so I i can still have the same mail aliases on the 
>lists.webnauts.net virtual domain
>as i have on my main domain.

This may be a clue.

>Problem being: if i now try to post to a list created with the modified 
>configuration, i get an error
>from the MTA, mail getting bounced:
>Oct 27 09:57:18 webnauts postfix/smtp[7808]: 820ED608167: 
>to=<test2 at lists.webnauts.net>, relay=none, delay=0, status=bounced (mail 
>for lists.webnauts.net loops back to myself)

This appears to be a postfix configuration problem that has nothing to
do with Mailman per se. However, my ignorant guess is that you have
entries for the same list name in both domains in your
'virtual-mailman' file and this is causing the confusion. At this
point, you may have to hand edit your 'aliases' and 'virtual-mailman'
files and run postalias and postmap.

Also, you don't say, and it has nothing to do with the problem, but if
you want the new mail domain for lists created prior to changing
mm_cfg.py, you need to manually change host_name on the General
Options page for those lists or run fix_url (run bin/fux_url.py for

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list