[Mailman-Users] SOLVED: Re: Mailman and Qmail - Cannot connect via SMTP

Douglas G. Phillips doug at sbscomp.net
Fri Jun 16 15:01:18 CEST 2006

Thanks for your reply Mark.  The problem was that the /etc/hosts file
was set to 600 for the permissions.  Resetting to 755 worked great.
Now I've run into another problem, but I've found plenty of info on

Thanks again.
----- Original Message -----
From: "Mark Sapiro" <msapiro at value.net>
To: "Douglas G. Phillips" <doug at sbscomp.net>; "Mailman Users ML"
<mailman-users at python.org>
Sent: Thursday, June 15, 2006 11:42 PM
Subject: Re: [Mailman-Users] Mailman and Qmail - Cannot connect via

> Douglas G. Phillips wrote:
> >Just a followup on this that I forgot to add: Messages sent to the
list are received by qmail and processed by mailman.  They appear in
the list archives, but they are not re-sent to the members of the
mailing list.
> That's consistent. The problem affects outgoing mail only.
> >  The only error that I can find is in the mailman error logs
(sample here):
> >  Jun 15 19:51:55 2006 (13082) Cannot connect to SMTP server
localhost on port smtp
> Mailman's OutgoingRunner is reporting that it called
> SMTPDirect.process() to send the message and the SMTP connect called
> in that module raised a socket.error exception.
> This is not quite the situation described at
> but the debugging techniques described there and in the referenced
> list posts should help.
> >  QMail is started via an /etc/init.d script that executes the
qmail-start binary.  I can telnet to the SMTP port fine from
localhost, and it accepts mail just fine.
> Are you telnetting to 'localhost' by name? As the 'mailman' user?
> --
> Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
> San Francisco Bay Area, California    better use your sense - B.

More information about the Mailman-Users mailing list