[Mailman-Users] Still can't send out from Mailman

Mark Sapiro msapiro at value.net
Thu Oct 26 23:54:13 CEST 2006

Dr. Scott S. Jones wrote:
>> You can try the following:
>> Give the command
>> /usr/lib/python2.x/smtplib.py
>fyrenice:/var/log/mailman# /usr/lib/python2.3/smtplib.py
>From: scott at fyrenice.com
>To: sanchiro at gmail.com
>Enter message, end with ^D:
>this is a test message, at M. Sapiro's suggestions. 
>This is only a test.
>Message length is 74
>send: 'ehlo localhost.localdomain\r\n'
>reply: '250-fyrenice.com Hello localhost []\r\n'
>reply: '250-SIZE 52428800\r\n'
>reply: '250-PIPELINING\r\n'
>reply: '250 HELP\r\n'
>reply: retcode (250); Msg: fyrenice.com Hello localhost []
>SIZE 52428800
>send: 'mail FROM:<scott at fyrenice.com> size=74\r\n'
>reply: '250 OK\r\n'
>reply: retcode (250); Msg: OK
>send: 'rcpt TO:<sanchiro at gmail.com>\r\n'
>reply: '250 Accepted\r\n'
>reply: retcode (250); Msg: Accepted
>send: 'data\r\n'
>reply: '354 Enter message, ending with "." on a line by itself\r\n'
>reply: retcode (354); Msg: Enter message, ending with "." on a line by itself
>data: (354, 'Enter message, ending with "." on a line by itself')
>send: "this is a test message, at M. Sapiro's suggestions. \r\nThis is only
>a test.\r\n.\r\n"
>reply: '250 OK id=1GdCfZ-0002XR-Fc\r\n'
>reply: retcode (250); Msg: OK id=1GdCfZ-0002XR-Fc
>data: (250, 'OK id=1GdCfZ-0002XR-Fc')
>send: 'quit\r\n'
>reply: '221 fyrenice.com closing connection\r\n'
>reply: retcode (221); Msg: fyrenice.com closing connection
>>From all the OK items, is it safe to say that worked correctly, aside from
>my failure to end with a '.' on a line by itself? 

Actually, you did just what you were supposed to do. Terminating the
data with '.' on a line by itself is part of the protocol and smtplib
did that - that's the '\r\n.\r\n' at the end of the data.

So the above test worked. Now the question is why doesn't it work when
Mailman does it.

Things to check/try.

Defaults.py should have

SMTPHOST = 'localhost'

These should not be changed in mm_cfg.py.

If the above test was not run as the Mailman user, run it as the
Mailman user ('mailman' or what ever it is on your system).

Try the above as an ordinary user, not root, no special permissions.

BTW, is Mailman using Python 2.3? I.e. is there another Python version
on the machine that Mailman might be using?

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list