[Mailman-Users] Message received by mailman and archives, but won't deliver

Brad Knowles brad at shub-internet.org
Fri Aug 31 00:23:09 CEST 2007

Check your Mailman "error" log file. I'm guessing that there is one or  
more malformed messages in the Mailman queue that is hosing things up.

Problem is, the real problem is usually before the errors start  
showing up in the logs. Start with what shows up in the logs and work  

I don't recall the exact FAQ number or URL, but search the FAQ wizard  
for "troubleshooting".

Brad Knowles <brad at shub-Internet.org>

Sent from my iPhone

On Aug 30, 2007, at 4:14 PM, "Kyle Banerjee" <kyle.banerjee at gmail.com>  

> Further clarification on this problem.
> It turns out that not everything is showing in the post log. After a
> certain amount of time, the messages that are not getting through
> appear in qfiles/out/*.pck
> I turned debug=1 in SMTPDirect.py but haven't uncovered anything.
> This is nuts, I'm willing to entertain even crazy speculation at  
> this point.
> kyle
> On 8/30/07, Kyle Banerjee <kyle.banerjee at gmail.com> wrote:
>>> You see just one outgoing message in your mail log? What,  
>>> precisely is
>>> actually showing up in your outgoing sendmail logs?
>>> Are you sure that your outgoing mail isn't being routed through
>>> another mail server somewhere, which might be throwing it away or
>>> causing it to be mis-recognized as spam?
>> There are a number of lists, one has about 5K people on it. If I send
>> a message to one that has only 5 people on it, I see something like:
>> Aug 30 18:25:00 innopacusers sm-mta[32967]: l7UIOfmI032960:
>> to=<name.removed at colorado.edu>, delay=00:00:13, xdelay=00:00:03,
>> mailer=esmtp, pri=155445, relay=mx15.colorado.edu. [],
>> dsn=2.0.0, stat=Sent (Ok: queued as D091E692112)
>> Aug 30 18:25:02 innopacusers sm-mta[32967]: l7UIOfmI032960:
>> to=<name.removed2 at mail.lib.msu.edu>, delay=00:00:15, xdelay=00:00:02,
>> mailer=esmtp, pri=155445, relay=mail1.mail.lib.msu.edu.  
>> [],
>> dsn=2.0.0, stat=Sent (
>> <47eed6660708301124u6bda99bbo92e00b4180ccad48 at mail.gmail.com> Queued
>> mail for delivery)
>> Aug 30 18:25:02 innopacusers sm-mta[32967]: STARTTLS=client,
>> relay=relay.oregonstate.edu., version=TLSv1/SSLv3, verify=FAIL,
>> cipher=DHE-RSA-AES256-SHA, bits=256/256
>> Aug 30 18:25:02 innopacusers sm-mta[32967]: l7UIOfmI032960:
>> to=<name.removed3 at oregonstate.edu>, delay=00:00:15, xdelay=00:00:00,
>> mailer=esmtp, pri=155445, relay=relay.oregonstate.edu.
>> [], dsn=2.0.0, stat=Sent (Ok: queued as 90B39410794)
>> Aug 30 18:25:03 innopacusers sm-mta[32960]: l7UIOfmJ032960:
>> from=<webguru-bounces at innopacusers.org>, size=11445, class=-30,
>> nrcpts=1, msgid=<47eed6660708301124u6bda99bbo92e00b4180ccad48 at mail.gmail.com 
>> >,
>> proto=ESMTP, daemon=MTA-v4, relay=localhost []
>> Aug 30 18:25:04 innopacusers sm-mta[32976]: l7UIOfmJ032960:
>> to=<name.removed4 at gmail.com>, delay=00:00:01, xdelay=00:00:01,
>> mailer=esmtp, pri=95445, relay=gmail-smtp-in.l.google.com.
>> [], dsn=2.0.0, stat=Sent (OK 1188498304 u62si752714pyb)
>> "webguru" is the name of this test list. The strange thing is that
>> we've been running for years with no problems. Yesterday, I was
>> getting errors with invalid character sets that seemed to be gumming
>> things up. I messed around with it to no avail, so I upgraded to the
>> latest version. I cleared out everything in process just to make sure
>> that nothing that hadn't been processed wasn't blocking everything
>> else.
>> When the problem was first reported, the logs looked OK to me, so I
>> told them there was a a delivery problem at their end. Then calls and
>> emails started pouring in, and I realized that I hadn't received any
>> messages even though I use gmail with no filters and I usually get
>> dozens of messages from one of our lists each day. I checked to make
>> sure we're not blacklisted and that seemed OK too. The weird thing is
>> that I can send email from the command line no problem, and
>> administrative messages (subscribe, unsubscribe, etc) seem to get
>> through just fine.
>> kyle
> -- 
> ----------------------------------------------------------
> Kyle Banerjee
> Digital Services Program Manager
> Orbis Cascade Alliance
> banerjek at uoregon.edu / 541.359.9599
> ------------------------------------------------------
> Mailman-Users mailing list
> Mailman-Users at python.org
> http://mail.python.org/mailman/listinfo/mailman-users
> Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
> Searchable Archives: http://www.mail-archive.com/mailman-users%40python.org/
> Unsubscribe: http://mail.python.org/mailman/options/mailman-users/brad%40shub-internet.org
> Security Policy: http://www.python.org/cgi-bin/faqw-mm.py?req=show&amp;file=faq01.027.htp

More information about the Mailman-Users mailing list