[Mailman-Users] error when going to list admin url

Mark Sapiro msapiro at value.net
Mon Jan 15 20:07:46 CET 2007

Steve Mueller wrote:
>Here's my story - I've installed Mailman with, at least seemingly, no
>issues.   I've run check_perms and all checked out ok.  I was able to create
>a list from the command line and I received the email indicating that the
>list had been created which also included the url's to the admin and user
>frontend for the list.  However, when I click on the admin URL I get the
>message below:
>Bug in Mailman version 2.1.9
>We're sorry, we hit a bug!
>Please inform the webmaster for this site of this problem. Printing of
>traceback and other system information has been explicitly inhibited, but
>the webmaster can find this information in the Mailman error logs. 
>I've looked in the logs and they are empty.  Do I have to turn logging on or
>is the a way to allow the printing of the traceback so I can get more info
>on the error?  

Two things:

1) check for the setting of LOG_DIR in Defaults.py and mm_cfg.py
(mm_cfg.py overrides Defaults.py) and make sure you are looking in the
correct place for the error log. Also make sure the log's group is the
mailman group and it is group writable and Mailman/cgi-bin/admin is
group mailman and SETGID.

2) in scripts/driver change the line


just after the comments at the beginning to


This will enable printing the traceback to the web browser.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list