[Mailman-Users] Content boundaries vanish from mime messages ininput queue

Lauren Weinstein lauren at vortex.com
Sat Nov 10 05:25:02 CET 2007

Mark, et al.,

Hi.  This is a source install that I've been using for a long time
mostly for locally generated messages and digests, but am now using
for large numbers of externally generated (moderated) message
distributions.  I should add that I also have removed (including all
white space -- and I set the configuration default for both to "")
the headers and footers for direct distribution (I've left in the
header for digests, on the assumption that won't be an issue).  I
had *thought* this had solved the main problem, and I have a test
message that apparently came through correctly, but later tests are
failing again.  I feel like the guy in the old movie "The 4D Man" who
kept trying to replicate the one time his tricky experiment worked.

What's happening is that messages coming through (and they look this
way in the moderator's preview as well) are being stripped of all
MIME boundaries -- I'll include an example below.  The boundaries
are clearly present (and the messages display correctly) on cc'd
versions that don't go through mailman.  During testing, I also had
an incident where it appeard that a newly arrived test message was
deleted unseen when a bunch of older messages were being deleted thru
the moderator interface, but I'm not ready to swear to that yet.
Different issue.

Example of the Mime problem follows.  Note that the crypto portion 
immediately follows the main text with no boundary, nor is there
a boundary at the end of the crypto section.  Any ideas appreciated!

>From the moderator interface:


Received: from chrome.vortex.com (chrome.vortex.com [])
	by neon.vortex.com (8.12.6/8.12.6) with ESMTP id lAA4JcRI001368
	for <test@[]>; Fri, 9 Nov 2007 20:19:38 -0800 (PST)
Received: from [] (nebula.vortex.com [])
	by chrome.vortex.com (8.12.6/8.12.6) with ESMTP id lAA4JcGm021330
	for <test>; Fri, 9 Nov 2007 20:19:38 -0800 (PST)
Message-ID: <4735315A.1020605 at vortex.com>
Date: Fri, 09 Nov 2007 20:19:38 -0800
From: Lauren Weinstein <lauren at vortex.com>
User-Agent: Thunderbird (Windows/20070728)
MIME-Version: 1.0
To: test
Subject: Test - signed MIME message
Content-Type: multipart/signed; protocol="application/x-pkcs7-signature";
	micalg=sha1; boundary="------------ms050600000604090002090408"


Signed section should follow

> Lauren Weinstein wrote:
> >Greetings.  On a 2.1.6 era mailman, I've discovered that any mime input 
> >messages are having their mime boundaries and related mime information 
> >stripped out from the message body.  All that remains is the 
> >Content-type header line.  As one would expect, this causes all sorts of 
> >problems for mime-aware UAs, since the various parts of the input 
> >messages are all cat'd together without any boundaries.
> >
> >Filters are OFF.
> >Scrubbing is OFF.
> Please give us more information. If filter_content is No and
> scrub_nondigest is No, messages sent to the list should have all the
> MIME headers, boundaries, and structure intact except for possibly
> wrapping the entire message structure in a higher level
> multipart/mixed message in order to add msg_header and/or msg_footer
> parts.
> Is this Mailman 2.1.6 installed from source or a package, and if a
> package, which?
> Under what circumstances are you seeing this?
> Do you have an example of a raw message as sent to the list and the
> corresponding raw message as received from the list or found in the
> archives/private/listname.mbox/listname.mbox file.
> -- 
> Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
> San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list