[Mailman-Users] Moderator password not working?

Dan Mashal dmashal at intertrust.com
Mon Oct 22 19:45:17 CEST 2007

Hi Mark,

Why so old? The system has been around since the dawn of time and hasn't
been upgraded since. It's running on an old sparc with Solaris. We are
going to be upgrading to the new version soon hopefully. As you know
though, it's not an easy task. :)

We seemed to just figure out the problem. We got the super duper mailman
password confused with a list administrator password.

That is, we are providing our users the list administrator/moderator
passwords and we are using the super duper password to login as
sysadmins. Thanks for your reply.


-----Original Message-----
From: Mark Sapiro [mailto:msapiro at value.net] 
Sent: Monday, October 22, 2007 10:39 AM
To: Dan Mashal; mailman-users at python.org
Subject: Re: [Mailman-Users] Moderator password not working?

Dan Mashal wrote:
>I created a new list using the newlist command. For some reason I had
>run fix_url after creating the list.

In Mailman 2.1.1 (why so old?) if you just specify list_name to
bin/newlist, the list will be created in the
DEFAULT_URL_HOST/DEFAULT_EMAIL_HOST domains. if you want these to be
different you have to create list_name at url_host, specifying the web
domain, not the email domain as url_host.

>Right now it seems that the
>moderator password does not work for this list (I know im using the
>right one).

Do you mean the moderator password or the list admin password?

>Any ideas why this might happen? We are using Mailman version 2.1.1. Is
>there some flag you need to set for moderators to login?

No, but the moderator password can't log in to the admin interface,
only to the admindb interface. Only the list admin or site admin
password can be used to log in to the admin interface.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list