[Mailman-Users] qrunner error

Myron Kowalski myron at cs.moravian.edu
Thu Oct 25 21:26:07 CEST 2007

I noticed that messages were not going out to my mailing lists. When
I restarted mailman, this comes up. Any mail sent to the list is  
being archived,
but is not going to the members.

Traceback (most recent call last):
   File "/users/mailman/bin/qrunner", line 270, in ?
   File "/users/mailman/bin/qrunner", line 230, in main
   File "/users/mailman/Mailman/Queue/Runner.py", line 65, in run
     filecnt = self._oneloop()
   File "/users/mailman/Mailman/Queue/Runner.py", line 93, in _oneloop
     msg, msgdata = self._switchboard.dequeue(filebase)
   File "/users/mailman/Mailman/Queue/Switchboard.py", line 156, in  
     data = self._ext_read(dbfile)
   File "/users/mailman/Mailman/Queue/Switchboard.py", line 262, in  
     dict = marshal.load(fp)
ValueError: bad marshal data

I'm running mailman 2.1.9 and python 2.3.4.

I created a list the other day and that's when I noticed the problem.  
I've since
deleted that list, but I still get the same error. I don't believe  
that was the problem

I found a check_request_db program on the web that seem to suggest an  
to my problem, but the program doesn't seem to do anything. I don't  
know any python,
so I don't know how to read that program. Any help would be  
appreciated. Thanks.

Myron Kowalski
MoCoSIN Network/Systems Administrator
Moravian College
myron at cs.moravian.edu

More information about the Mailman-Users mailing list