[Mailman-Users] Permissions issue w/ Apache

Bill Honneus (honneus) honneus at cisco.com
Fri May 2 00:07:02 CEST 2008

Thanks, Mark.  It looks like this is working now.

Much appreciated!


-----Original Message-----
From: Mark Sapiro [mailto:mark at msapiro.net] 
Sent: Thursday, May 01, 2008 5:55 PM
To: Bill Honneus (honneus); mailman-users at python.org
Subject: RE: [Mailman-Users] Permissions issue w/ Apache

Bill Honneus 
>That was the problem.  I added that directory statement and I now get 
>an error page showing the following:
>Mailman CGI error!!!
>The Mailman CGI wrapper encountered a fatal error. This entry is being 
>stored in your syslog:
>Group mismatch error.  Mailman expected the CGI wrapper script to be 
>executed as group "nobody", but the system's web server executed the 
>CGI script as group "apache".  Try tweaking the web server to run the 
>script as group "nobody", or re-run configure, providing the command 
>line option `--with-cgi-gid=apache'.
>This seems self explanatory enough.  So now if I run ./configure again 
>from my original staging area with the above mentioned option, will I 
>need to run "make install" again afterwards and redo all my original 
>custom configuration?

I'm not sure what you mean by "custom configuration", but any changes
you have made in mm_cfg.py will not be affected by the ./configure, make
install process which never overwrites an existing mm_cfg.py.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list