[Mailman-Users] Mailman 2.1.12 - Python 2.4.[456]incompatibility

Barry Finkel b19141 at anl.gov
Thu Apr 23 23:03:42 CEST 2009

I wrote, in part:
>>Or do I have to specify something to get the Mailman-supplied
>>e-mail package untarred?  Thanks.

and Mark Sapiro replied:
>That would be another approach. After running ./configure and before
>running any make commands, you could edit misc/Makefile to replace the
>     EMAILPKG=       email-2.5.8
>to install email 2.5.8 in Mailman's pythonlib. Then you wouldn't need
>to patch anything. But, how this fits with the Ubuntu package, I don't
>Note that the only Charset.py that needs patching is the one from email
>3.0.2 which shipped only with Python 2.4.4 through python 2.4.6

My Python version is 2.4.3, and I ran a modified conftest.py program
from the configure script to determine that the email package is 3.0.1.
I could not determine the package  version number from looking at the
.py modules in /usr/lib/python2.4/email on my Ubuntu Mailman machine.
Barry S. Finkel
Computing and Information Systems Division
Argonne National Laboratory          Phone:    +1 (630) 252-7277
9700 South Cass Avenue               Facsimile:+1 (630) 252-4601
Building 222, Room D209              Internet: BSFinkel at anl.gov
Argonne, IL   60439-4828             IBMMAIL:  I1004994

More information about the Mailman-Users mailing list