[Mailman-Users] Problem with mailman install

LuKreme kremels at kreme.com
Thu May 14 20:12:44 CEST 2009

I have had mailman running for many years now, and have updated it  
semi regularly over the years (currently 2.1.9).

A few days ago, I tried to post a message to a list I host and got:

Command died with
    status 4: "/usr/local/mailman/mail/mailman post listname". Command  
    No such file or directory

I went in and tried to look at the install, but everything appeared to  
be fine. So I tried to reinstall via portupgrade mailman.

After the upgrade completed, I got this error:

  Command died with
    status 2: "/usr/local/mailman/mail/mailman post gfamily". Command  
    Group mismatch error.  Mailman expected the mail wrapper script to  
    executed as group "mailman", but the system's mail server executed  
the mail
    script as group "nobody".

This is odd since my current install of mailman has permissions like  

So I tried
$ export MM_USERNAME=nobody
$ export MM_GROUPNAME=nobody
$ export MM_USERID=65534

and made sure that in pkgtools.conf I had

'mail/mailman' => 'WITH_MAIL_GID=nobody',

and ran the port install again, only to get the same error. At each  
step I ran bin/check_perms and nothing was wrong.

Finally I just went into my backups and restored /usr/local/mailman  
with a cp -rp and now everything works (except ports thinks I have  
version 2.1.11)

So, for future reference, what SHOULD I have done?  And does anyone  
know how to tell ports I have 2.1.9 instead of 2.1.11?

Do not meddle in the affairs of Dragons for you are crunchy and
	taste good with ketchup

More information about the Mailman-Users mailing list