[Mailman-Users] Problem with mailman install

Mark Sapiro mark at msapiro.net
Mon May 18 03:29:20 CEST 2009

LuKreme wrote:
>A few days ago, I tried to post a message to a list I host and got:
>Command died with
>    status 4: "/usr/local/mailman/mail/mailman post listname". Command  
>    No such file or directory

status 4 means the execve that runs python returned. The "no such file
or directory" can refer to either /usr/local/mailman/mail/mailman or
to the path to Python that the mail wrapper is using.

>I went in and tried to look at the install, but everything appeared to  
>be fine. So I tried to reinstall via portupgrade mailman.
>After the upgrade completed, I got this error:
>  Command died with
>    status 2: "/usr/local/mailman/mail/mailman post gfamily". Command  
>    Group mismatch error.  Mailman expected the mail wrapper script to  
>    executed as group "mailman", but the system's mail server executed  
>the mail
>    script as group "nobody".
>This is odd since my current install of mailman has permissions like  

See the FAQ at <http://wiki.list.org/x/tYA9> to understand more about
this error.

>So I tried
>$ export MM_USERNAME=nobody
>$ export MM_GROUPNAME=nobody
>$ export MM_USERID=65534
>and made sure that in pkgtools.conf I had
>'mail/mailman' => 'WITH_MAIL_GID=nobody',
>and ran the port install again, only to get the same error. At each  
>step I ran bin/check_perms and nothing was wrong.

I can't help you much with all this package specific stuff. You might
be better off asking for help using resources specific to the package
you are installing.

My guess is that the 'WITH_MAIL_GID=nobody' change should have fixed
the group mismatch problem, particularly if the prior setting was
'WITH_MAIL_GID=mailman'. Possibly the environment changes messed this
up somehow.

>Finally I just went into my backups and restored /usr/local/mailman  
>with a cp -rp and now everything works (except ports thinks I have  
>version 2.1.11)
>So, for future reference, what SHOULD I have done?  And does anyone  
>know how to tell ports I have 2.1.9 instead of 2.1.11?

If you have a file named last_mailman_version in Mailman's data/
directory, it probably has contents


If so, change the contents to


I don't know what you SHOULD have done to fix the original problem,
since I don't know what the underlying cause was.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list