[Mailman-Users] check_perms does not fix permissions

Adam McGreggor adam-mailman at amyl.org.uk
Mon May 25 22:01:37 CEST 2009

On Mon, May 25, 2009 at 08:04:39AM -0700, Mark Sapiro wrote:
> >Problems found: 1283
> >Re-run as list (or root) with -f flag to fix
> The most likely explanation is there are directories in Mailman's tree
> that are symlinks. check_perms looks at the permissions of the link
> itself (generally rwxrwxrwx) and complain's about those. Then when it
> tries to fix them, it is the permissions of the target that are
> changed, and the link still has the permissions check_perms doesn't
> like.

FWIW, I've certainly noticed that (symlinks) to be the case with the
Debian packaged versions of Mailman.

(I've still not had a chance to build the Umbungo version of 2.1.12 I
was going to, but had I, I probably would have tried a fix for
that/this issue, someway or another. It's an annoyance to me.)

Saying that, I'd not expect there to be 1283 problems...

``Burnham's ideas appear in `1984', more or less
  unchanged by their passage through Orwell.''
  (Phil Edwards on oligarchical collectivism)

More information about the Mailman-Users mailing list