[Mailman-Users] icons not seen

Mark Sapiro mark at msapiro.net
Thu May 28 23:20:43 CEST 2009

admin2 wrote:

>Okay I give up.  how can I figure out why my icons are not seen via apache.
># ls -l /var/lib/mailman/icons/
>total 24
>-rw-r--r-- 1 root root  945 Mar  6  2008 PythonPowered.png
>-rw-r--r-- 1 root root 3049 Mar  6  2008 gnu-head-tiny.jpg
>-rw-r--r-- 1 root root 6150 Mar  6  2008 mailman-large.jpg
>-rw-r--r-- 1 root root 2022 Mar  6  2008 mailman.jpg
>-rw-r--r-- 1 root root  281 Mar  6  2008 mm-icon.png
>Here is the config:
><VirtualHost *:80>
>         ServerAdmin webmaster at domain.com
>         ServerName lists.domain.com
>         ServerAlias www.lists.domain.com w.lists.domain.com
>         ServerAlias ww.lists.domain.com wwww.lists.domain.com
>         DocumentRoot /var/www
>         ScriptAlias /mailman /var/lib/mailman/cgi-bin/
>         Alias /pipermail /var/lib/mailman/archives/public/
>         Alias /icons /var/lib/mailman/icons/

Normally, Alias and ScriptAlias entries should have either both entries
or neither entry terminated with a slash. E.g.

         Alias /icons /var/lib/mailman/icons
         Alias /icons/ /var/lib/mailman/icons/

but I don't think that's the actual problem here. Do you have something
other than

IMAGE_LOGOS = '/icons/'

in mm_cfg.py?

Also, while it isn't necessary, a common way to do this is do eliminate
the Alias for icons and just copy the Mailman icons to (in your case)


Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list