[Mailman-Users] Error message on upgrade

dhottinger at harrisonburg.k12.va.us dhottinger at harrisonburg.k12.va.us
Mon Oct 26 19:02:18 CET 2009

I upgraded our version of mailman from 2.0.x to the newest release of  
2.1.12rc2 using ./configure --prefix=/var/mailman  
--with-cgi-gid=apache --with-python=/usr/bin/python2.4.  I started  
mailman using the mailmanctl script.  As soon as I did, I started  
getting the following error from the qrunner:
Traceback (most recent call last):
   File "/var/mailman/cron/qrunner", line 89, in ?
     from Mailman.Handlers import HandlerAPI
   File "/var/mailman/Mailman/Handlers/HandlerAPI.py", line 26, in ?
     from Mailman.pythonlib.StringIO import StringIO
ImportError: No module named pythonlib.StringIO.

I did some googling and found quite some people with the same error,  
but no real fixes.  Does anyone have a fix for this?  Im running  
2.6.20-1.2944.fc6PAE #1 SMP Tue Apr 10 18:21:36 EDT 2007 i686 i686  
i386 GNU/Linux, on Fedora.



Dwayne Hottinger
Network Administrator
Harrisonburg City Public Schools

"Everything should be made as simple as possible, but not simpler."
-- Albert Einstein

"The hottest places in Hell are reserved for those who, in times of moral
crisis, preserved their neutrality."
-- Dante

More information about the Mailman-Users mailing list