[Mailman-Users] Error message on upgrade

Mark Sapiro mark at msapiro.net
Mon Oct 26 20:18:55 CET 2009

dhottinger at harrisonburg.k12.va.us wrote:

>I upgraded our version of mailman from 2.0.x to the newest release of  
>2.1.12rc2 using ./configure --prefix=/var/mailman  
>--with-cgi-gid=apache --with-python=/usr/bin/python2.4.  I started  
>mailman using the mailmanctl script.  As soon as I did, I started  
>getting the following error from the qrunner:
>Traceback (most recent call last):
>   File "/var/mailman/cron/qrunner", line 89, in ?
>     from Mailman.Handlers import HandlerAPI
>   File "/var/mailman/Mailman/Handlers/HandlerAPI.py", line 26, in ?
>     from Mailman.pythonlib.StringIO import StringIO
>ImportError: No module named pythonlib.StringIO.

The latest official release is 2.1.12, not 2.1.12rc2. There was at
least one significant bug fix between rc2 and the final.

As far as the above error is concerned, qrunners are no longer run by
cron in mailman 2.1.x. cron is running /var/mailman/cron/qrunner which
is from 2.0 and clearly won't work. You need to update Mailman's
crontab to run the 2.1 cron jobs only.

Actually, your 2.1.12rc1 Mailman is probably working fine. It's just
/var/mailman/cron/qrunner should be removed and the entry that runs it
removed from Mailman's crontab.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list