[Mailman-Users] Python compatibility - was: command line administration.

Mark Sapiro mark at msapiro.net
Thu Sep 24 23:51:27 CEST 2009

Rob Lingelbach wrote:
>In order to edit the postings I have this in mm_cfg.py:
># this is to be able to edit held messages to kill advertising
># remember to insert blurb that msg was edited
># messages will now be held as .txt  (less efficient)

I have nothing to add to the subject topic, but I just want to point
out that the Python 2.6.x incompatibility I mention in the post at
also affects holding messages when HOLD_MESSAGES_AS_PICKLES = No.

Just for information, Mailman versions older than 2.1.12 are
incompatible with Python 2.6.x. Mailman 2.1.12 was intended to be
fully compatible with Python 2.6.x, but we missed one change which
only affects preserving messages for the admin from the admindb
interface and holding messages as text files. A patch for this issue 
is in the above post. This does not affect Mailman 2.1.12 when used
with Python 2.4.x or 2.5.x. See the FAQ at
<http://wiki.list.org/x/pYA9> for more detail.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list