[Mailman-Users] python 3 and mailman 2.1.12

Mark Sapiro mark at msapiro.net
Fri Mar 18 03:40:58 CET 2011

Barry Warsaw wrote:
>On Mar 17, 2011, at 04:23 PM, Hal Huntley wrote:
>>Or is 2.1.14 compatible with python 3?
>No.  Mailman 3 will be ported to Python 3 when its dependency stack has been
>ported.  Right now, some of the Zope packages are blockers.

To elaborate a bit, there are no plans to ever make the 2.1 branch
Python 3 compatible. If you install Mailman 2.1.x from source, you can
configure it to use any Python on the system with the --with-python
option to configure. Downstream packages may or may not provide a way
to use other than the default Python.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list