[Mailman-Users] Mailman lists are set up but posts to the lists arenot arriving

Mark Sapiro mark at msapiro.net
Fri Sep 16 07:07:22 CEST 2011

jhock wrote:
>I have set up Mailman and can create lists etc. I can subscribe to the
>lists but I can't post to the lists. The posts don't get delivered.
>I have looked at the FAQs and searched the WIKI but I can't find an
>answer to my problem. I have been working on this for days. Cann someone
>please help me?
>I using:
>Mailman version: 2.1.14
>Python 2.5.2
>Debian GNU/Linux 5.0.5
>Exim version 4.69 #1 built 30-Sep-2008 18:54:33
>my configuration is:
>MAILMAN_USER = 'mailman'
>MAILMAN_GROUP = 'mailman'
>--with-mail-gid=Debian-exim --with-cgi-gid=www-data

The above is wrong. Assuming that

MAILMAN_USER = 'mailman'
MAILMAN_GROUP = 'mailman'

are from your exim config and 

--with-mail-gid=Debian-exim --with-cgi-gid=www-data

were options to configure, it should have been


I.e. whateve you configure with --with-mail-gid must match

>I have tried to apply to the content of section 6.2 in the

Did you read the note at the beginning of section 6.2 which says in
part "The updated document is here:
http://www.exim.org/howto/mailman21.html and is recommended over the
information in the subsections below if you are using Exim 4."

>The content of my:
>apache error logs and
>mailman error logs
>tell me nothing that I can understand.

Well, you are coming here for help because we might be able to
understand what's in those logs, but not if we don't see them. The
apache logs aren't relevant to "can't post" issues, but the other's
are, so what's in them.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list